Lightroom 4 & Nik’s Filters a big NO???

I just received my Lightroom 4 upgrade and what a surprise – after the installation all my Nik Software plugins dind’t work.
I check on Nik’s website and downloaded the latest versions, which is stated to support Lightroom 4, but the result was the same. The only filter that is working correctly is HDR Efex Pro. For all the rest under “Edit In” menu I get this message:

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Unexpected error performing command:
bad argument #1 to ‘lower’ (string expected, got nil)
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

The plugins DO work with the Lightroom 4 beta, but not with the original version 4.
I sent an e-mail to Nik’s support – still waiting for answer. I’ll keep you posted of how the problem is developing.
I believe this is a situation that all of the current Lightroom and Nik’s users will experience these days after they upgrade to LR4.

Meanwhile here are two links to different forums which also discuss this problem:
http://forums.adobe.com/thread/971432?start=0&tstart=0
and:
http://feedback.photoshop.com/photoshop_family/topics/lr4_external_editor_failure

Do you have the same problem? Let me know if anybody already heard from Nik or Adobe for a solution.

UPDATE:
—————
I spoke with Adobe support and they are recognizing the problem. They said their programmers are working on this and will include the solution in a patch soon.
Here is the official article on Adobe sites:
http://blogs.adobe.com/lightroomjournal/2012/03/lightroom-4-hot-issues.html

http://feedback.photoshop.com/photoshop_family/topics/lr4_external_editor_failure

UPDATE 2:
—————
While waiting for Adobe to solve all their problems with Lightroom 4 and THEN to release a patch, here is a solution I find best for me. Simply go to http://labs.adobe.com/downloads/photoshopcs6.html and download Photoshop CS6. It is a 60 days trial. It should be enough time for Adobe to release a patch. Meanwhile CS6 is truly amazing – I’m sure you’ll like it too.
After installing Photoshop CS6 trial – all NIK’s plugins work like charm!

Share: